Talk:FreeMind on Linux

From FreeMind

Revision as of 04:31, 11 November 2007 by Gtvieira (Talk | contribs)
Jump to: navigation, search

FreeMind is great! I have a great idea for a similar program only with a different feature set. What I want to know more about is how you start an open source software project. I have an idea and a beginning of a design, but how do I get more people involved?

Thanks in advance for any help / inspiration / tips.

David

Contents

wrong command in 'apt-get install' section?

for me the given command for installing freemind by using apt-get didn't work:

apt-get install freemind/experimental freemind-plugins-svg/experimental freemind-plugins-time/experimental freemind-plugins-time/experimental

i found out i had to delete the /experimental, then:

apt-get install freemind freemind-plugins-svg freemind-plugins-time freemind-plugins-time

worked fine

guess you should leave the /experimental in the sources.list away if you want to have the originall command working?

am i right or am i wrong? not sure whether i did the whole stuff an other way or the wiki put the wrong command so i didn't change it...

schaffner


You probably did it right. This is something that's going to vary with time, especially where Debian Experimental is concerned. Experimental isn't a formal part of Debian, but it is often used by developers when introducing a big change to a package. At the time of writing FreeMind is not in experimental. The available versions look like this:

warren:~# apt-cache policy freemind
freemind:
  Installed: 0.8.0+01-4
  Candidate: 0.8.0+01-4
  Version table:
 *** 0.8.0+01-4 0
        100 /var/lib/dpkg/status
     0.7.1-6 0
        500 http://proxy sarge/contrib Packages
        600 http://proxy etch/contrib Packages
          3 http://proxy unstable/contrib Packages

Version 0.8.0+01-4 consists of the .debs from Sourceforge.

If you want to play with experimental, you need to add this to sources.list:

deb http://ftp.uk.debian.org/debian/ ../project/experimental contrib main non-free

but be careful, experimental packages can break other things.

NickLeverton 11:20, 5 Jul 2007 (PDT)

(K)Ubuntu Instructions work on Ubuntu Edgy . . . I think ... confirmed

The instructions and link to the blog post (and its attendant comments) helped me manage to make FreeMind work on Ubuntu 6.10 (EdgyEft). I can't quite remember the combination of procedures, but it works for me now. Highlights:

  1. I did install the j2re1.4 package (blackdown java)
  2. I didn't have to edit any files (but I am configured to use the the multiverse & universe repos already).
  3. I downloaded the .deb on the FreeMind website and installed it.
  4. I used apt-get -f install to fix broken dependencies.

Then, it Just Worked.

--Tex 10:02, 29 Dec 2006 (PST)

Thanks to the tip 'apt-get -f install' it worked for me as well - with first try. I wrote how in the article under 'confirmed more easy install within Kubuntu 6.10'. Thanks, Tex!

--Patmuk 17:24, 29 Jan 2007 (PST)

I'm happy that it works for you, but you're actually first breaking your system by installing FreeMind without taking care of the dependencies, and then repairing it using apt-get -f install. The correct way to do it is really to add the FreeMind repositories to your sources and then install freemind using apt-get install freemind.

Furthermore your instructions might let other, not having multiverse and universe setup, think that it's easier than it actually is. For these reasons, I allow myself to update your notes. Hope this is OK.

--Ewl 05:03, 25 Mar 2007 (PDT)

Folks, Freemind is java based, so if you already have Java installed, no need to futz around with your apt configuration. Just download the binary tar ball and run it. I did this on my system since I had Sun's JDK installed which Oracle depended on and I didn't want to break that.

--Javester 10:04, 12 Apr 2007 (PDT)

Repositories keys ?

Hi, is there a place where the pgp keys for http://eric.lavar.de/comp/linux/debian/ can be found ?

The freemind package installs fine on an ubuntu Feisty (7.04), but there is a warning:

root@epine:~# apt-get install freemind
Reading package lists... Done
Building dependency tree       
...
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 3304kB of archives.
After unpacking 7864kB of additional disk space will be used.
Do you want to continue [Y/n]? 
WARNING: The following packages cannot be authenticated!
  freemind
Install these packages without verification [y/N]? y
...

window size

I am running ubuntu feisty 7.04 with sun java 1.6 installed. I can install the app and it runs but the window is small and if i drag it to make it larger, the window gets bigger, but the map stays the original small size. Anyone else experiencing this? I used Freemind in Windows and would like to get it to run on Ubuntu.

Comment on: When resizing the FreeMind window, the inner field doesn't resize properly (or other GUI strangeness)

Under Beryl, setting the variable

export AWT_TOOLKIT=MToolkit

fixes the problem. It's a common Java problem under Beryl. Variable should be set in your /etc/environment or in your ~/.profile .

and where should this line of code reside for compiz?

I have the same window problem and no Beryl installed. Any help, please?

Personal tools